CallHippo Web Dashboard Service Disruption

Incident Report for CallHippo

Resolved

The web dashboard is fully operational again. All features and data are accessible. Thank you for bearing with us.
Posted Mar 25, 2026 - 09:48 UTC

Investigating

We're experiencing an issue with the CallHippo web dashboard. Our team is actively investigating and working on a fix, no call data is at risk.
Posted Mar 25, 2026 - 09:44 UTC