Callhippo services are currently operating normally. We are no longer observing elevated errors or latency across the network.
This incident has been resolved.
Posted Nov 19, 2025 - 03:40 UTC
Monitoring
A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 14:43 UTC
Update
We are seeing services recover, but customers may continue to observe higher-than-normal error rates as we continue remediation efforts.
Posted Nov 18, 2025 - 13:00 UTC
Identified
We are currently experiencing an issue due to a Cloudflare outage affecting CallHippo services. Our team is closely monitoring the situation and working on a resolution. Some users may experience service disruptions. We appreciate your patience and will provide updates as soon as possible.
Posted Nov 18, 2025 - 12:07 UTC
Investigating
Callhippo is aware of, and investigating an issue which potentially impacts multiple customers. Further detail will be provided as more information becomes available.
Posted Nov 18, 2025 - 11:54 UTC
This incident affected: Servers Availability, Callhippo Website, Admin Dashboard, Incoming Calls, Outgoing Calls, Callhippo Apps, Integrations, and Public API.