CallHippo Dialer & Calling Service Disruption

Incident Report for CallHippo

Resolved

The dialer and calling services are back to normal. We're sorry for the inconvenience caused.
Posted May 14, 2026 - 15:05 UTC

Investigating

We're investigating a disruption affecting the CallHippo dialer and calling services. Our engineers are working urgently to restore full service.
Posted May 14, 2026 - 15:04 UTC